Joomla

Module problems when using SH404SEF?

SUGGESTION:  When looking for a quick fix, read the text in GREEN only.  The rest I pretty much wrote for myself. 

SH404SEF is a good module.  No, make that a great module.  But today, it scared two of my colleagues who are not as ‘stress-prone’ as me.  My usual reply when something goes wrong is ‘Yeah, I know, I’ll fix it later’. 

But today, my mind was blown for a second.  We were working on a website, and I had just installed SH404SEF to take care of the SEO part.  Which works great, in general.  There’s only a minor problem:  SH404SEF doesn’t always play nice with your modules, or so it seems. 

The situation

Modules didn’t show where they were supposed to  – that is, along side our articles when clicking through to an article after opening a certain menu item  We didn’t have this problem before we used SEF URL’s so that pointed into the direction of SH404SEF as source of the problem.

The reason?  Problems with your ItemID when using SH404SEF to convert your non-SEF urls to SEF URLSs.  Since modules are linked to an ItemID this means trouble. 

Note for myself:  Modules are connected to ItemID’s, which in turn are generated by menu items.  That doesn’t mean that you need to create an article for each and every article in your Joomla site.  If you’ve got one article which is linked to a menu item, you can link it to another article – and it ‘inherits’ the ItemID of the original article (unless you explicitly link it to an article which uses another ItemID or no ItemID at all – ergo, you’ll see the modules displayed for all articles with the same ItemID.

See for yourself:  Change the ItemID / Remove the ItemID of an article which previously showed modules on a page, and they might vanish / change to another model.  Cool, yet complex.   

The solution

You can try the following solution to solve the ItemID problem – it worked for me. 

  1. In the Admin Panel, open de SH404SEF component
  2. Go to Configuration –> SH404SEF Configuration
  3. Click the Advanced Tab
  4. Under the ItemID Management Section, set ‘Insert Menu ItemID if none’ to ‘yes’

This may solve your problem of ‘missing module items.’

Sometimes, I still find Joomla! to be complex.  I hope this post made any sense; and if it’s any help to you, make sure to leave a comment!  

Advertisements

Categories: Joomla

Tagged as: , , , , , ,

4 replies »

  1. Hi, thanks for the thread. I am having the same problem as raj. I changed the Insert menu itemid but the modules are still missing. Any help would be greatly received. Craig

    Like

  2. Hai,

    I tried doing the same , on my site some modules are not showing up on certain pages. . I tried changing Insert Menu ItemID if none’ to ‘yes. But the problem persists. Do i have to do any more changes?

    I will be glad if you able to help in this issue.

    Thanks
    Raj

    Like