Various Articles

How to find the PHP version of your host inside Joomla 3.x

In a recent blog post, Joomla announced that they will be increasing the minimum PHP requirements for Joomla 3.3 to PHP 5.3.10. You can read more about their motivations here.

If you are curious to find out what PHP version you’re on right now, you can find out from inside Joomla. Here’s how it’s done:

1. Click System > System Information
2. Look for “PHP Version”, and make a (mental) note.

  • Are you on PHP 5.3.10 or higher (e.g 5.4.x or 5.5.x)? Then you’ve got nothing to worry about
  • Are you using a version under PHP 5.3.10? Then urge your host to upgrade. If they won’t, find a hosting company that doesn’t communicate with you using carrier pidgeons and which supporters proper PHP versions.
  • Note: We don’t recommend running anything under the latest version of the series (5.3.27) regardless of PHP requirements. And if they’re available to you, PHP 5.4 and PHP 5.5 will make your Joomla 3.x site significantly faster. The higher your PHP version, the beter!

We’ve made a 10 second video for you to help you find your PHP version. We messed up the video a bit, but we hope it gets the message across.

Advertisements

Categories: Various Articles