Joomla

Pike in attempt to abuse old Joomla exploits

Is your mailbox currently blowing up with Admintools notifications? Then you’re not alone. We’re noticing a definite spike in attempts to abuse Joomla exploits. The exploits the “attackers” are using are for older versions of Joomla.

Using Admintools or a similar tool will help you to block these malicious attempts to screw with your site. But instead of patching those holes, it’s better to make sure that the holes aren’t there.

How?

Make sure that you’re running the latest version of Joomla. We know it’s not always within your means to update that 2.5 or 1.5 website. Clients aren’t willing to pay. And you don’t work for free. We get that.

But, if it’s within your means, now is a good time to update those older sites. Actually, last year was a good time, but it’s better to be late than sorry. Joomla 3.x is the latest release and should be supported for a long time from now.

On top of a more secure version, you’ll get the following features:

  • A CMS that wasn’t built years ago
  • A faster Joomla
  • Better UI with more configuration options
  • Detailed UI
  • No more “Your old crap site isn’t supported, you moron” from both developers and your Joomla site itself (See for reference: Joomla 2.5 sites displaying a message it’s outdated)

Gentlemen, start your analysis of your old sites and get to updating.

Advertisements